Reporting Issues
Incident Report for Kissmetrics
Resolved
This incident has been resolved.
Posted Apr 28, 2016 - 09:48 PDT
Investigating
We are currently investigating an issue with our reporting infrastructure.
Posted Apr 28, 2016 - 08:55 PDT